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Perform3D v8.0.0 Release Notes
© 2021 Computers and Structures, Inc.

Notice Date: 12-June-2021

This document lists changes made to Perform3D since v7.0.0, released 30-January-2018. Items marked
with an asterisk (*) in the first column are more significant.

Analysis
Enhancements Implemented
* Ticket Description

2122 An enhancement was made to increase the maximum number of mode shapes allowed for
each analysis series from 50 to 99.

5771 The Run/Set Up Analyses task (Analysis phase) has been enhanced so that the existing
analysis lists for each analysis series will be copied to a new model created when the model
is saved as a new structure (File menu > Save as a New Structure).

5772 The Run/Set Up Analyses task (Analysis phase) has been updated so all analyses that have
been run will be moved to the analysis list when using the "Delete analysis results but keep
Analysis Series" settings. In previous versions, some analyses, such as Response Spectrum
load cases, would not be moved to the analysis list.

Data Files
Enhancements Implemented
* Ticket Description
* 1893 An enhancement was made to allow earthquake records with more than 32,692 time steps

to be used.
6463 Limited support is provided for running models and viewing results when the model files are

located in a local folder that is synced with OneDrive cloud storage. While this usually works
well, some limitations should be noted: (1.) The model file should be located on a local drive
and synced with cloud storage, not directly located on the cloud storage. Direct file reading
and writing to the cloud is not supported. (2.) Adequate storage needs to be available on the
local machine as well as at the synced cloud storage location. (3.) It is recommended to have
administrative rights on the local machine. (4.) It is not recommended that the logins for the
local machine and the cloud storage be for the same domain but different users. (5.)
Internet connectivity should be fast and reliable when working with a model in a synced
folder, otherwise analysis may be slow or may not complete. (6.) The same model should
not be run on multiple machines that are synced to the same cloud storage location. This
could result in incomplete or incorrect results. For best performance, it is recommended to
run and view the model in a folder that is not synced to cloud storage, then copy the files to
the synced folder later for backup and sharing. Alternatively, syncing can be paused or
disconnected while the model is in use.

Database Tables
Enhancements Implemented
* Ticket Description
* 4238 Analysis results and performance measures can now be displayed and exported in table

format, replacing the need to read results from binary files. Displayed tables can be accessed
using the menu command Table > Show Tables and can be filtered and sorted. Tables can be
exported in text, XML, Excel, and Access formats using the command File > Export.
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* Ticket Description
* 4894 Tabular output can now be defined for automatic export after the analysis is compete using

the command Tables > Define Automatic Tabular Output. When enabled, this will save the
specified output tables in either XML, Microsoft Excel, or Microsoft Access formats. The
following features are available for configuring the output tables: (1.) Table named sets can
be defined using command Tables > Define Table Named Sets and can be used to specify a
pre-selected set of output tables. (2.) Selection Groups can be defined in the Selection
Groups section of the Select For Nodes and Elements form (Tables > Show Tables) and can
be used to specify a pre-selected group of nodes and elements when the output table
results are limited by selection. See also Ticket 4238 of this release for additional
information about tabular output.

* 4895 An enhancement was added for automatic tabular output after analysis is complete (Tables
menu > Define Automatic Tabular Output). For each tabular output file, a Table Named Set
(Tables menu > Define Table Named Sets) and Table Selection Group (Tables menu > Show
Tables) can be specified to limit the output contents. Multiple tabular output files can be
defined. See also Ticket 4238 for more information on tabular data.

Documentation
Enhancements Implemented
* Ticket Description
* 3943 Help documentation is now available from within the software using the Help > Perform3D

Help command. Context-sensitive topics are available by pressing the F1 key when actively
using the various forms (dialogs) within the graphical user interface. The Help menu also
includes access to all manuals and documentation that are included with the installations,
and links to online resources for further information.

Graphics
Enhancements Implemented
* Ticket Description

4618 A new menu command, Options >Set Display Options, has been added to control aspects of
the model display such as whether or not to show node and element names, sizes of the
objects and text, and the choice between a dark- or light-colored theme.

* 6106 Several enhancements were made to the graphical display of the model: (1.) A Dynamic
Rotation button has been added to the toolbar to enable rotation of the view around the
horizontal and vertical axes. (2.) The Aperture Angle can now be used to set the perspective
view. Previously this was done by defining the distance ratio, which is still available. (3.)
White and Black background themes have been added to the Display Options form. (4.)
Options to show an extruded view of 2-node elements and to graphically display hinge
locations have been added to the Display Options form.

Installation and Licensing
Enhancements Implemented
* Ticket Description
* 2178 The version number has been changed to v8.0.0 for a new major release. A new v8 license

will be required. Note that the name of the data folder in the user Documents location has
been changed from PERFORM-3D to Perform3D.

* 4234 Perform3D now utilizes cloud licensing by default, allowing access to the license by multiple
users and/or from multiple machines. The number of simultaneous users corresponds to the
number of licenses owned. Cloud licensing requires connection to the internet while using
the software, either directly or through a proxy. Connection to a company network or VPN is
not necessary. Licenses can be checked out for a limited time period to allow use while
disconnected from the internet. Legacy licensing options (Standalone and Network) are still
available upon request.
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Results Display and Output
Enhancements Implemented
* Ticket Description
* 2085 An enhancement was made to allow element-force and drift results files to exceed 2 GB. In

earlier versions the software would give an error condition when using the "Combinations
and Envelopes" task of the Analysis Phase if files exceeded this size limit.

* 4634 An enhancement was made to allow printing of the deflected shape and mode-shape
displays, including a new print preview feature.

User Interface
Enhancements Implemented
* Ticket Description
* 2181 A new graphical user interface has been developed to provide improved functionality and

graphical clarity.
4518 An enhancement was made to enable toolbar buttons for zoom, middle-mouse button for

pan, and mouse-wheel for zoom operations in the Modal Analysis Results and Deflected
Shapes tasks (Analysis Phase). The zoom in/out and pan capabilities are not available during
animation. Note that printing of the display is only available when the full view is shown.

* 4619 Properties of individual nodes and elements can now be viewed by right-clicking on them
when viewing the undeformed shape of the structure. This will include identification,
location, geometry, assignments, and loading, as appropriate.

5768 An enhancement was made to the component import and export feature (Component
Properties task in the Build phase) so a user-defined path can be pasted in the "Read
Component Properties from a File" and "Write Component Properties to a File" form. This is
an alternative to the existing option to use the default folder or browse for a folder location.
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Analysis
Incidents Resolved
* Ticket Description
* 3359 An incident was resolved where one or more of the following data might have been

erroneously obtained from a different Analysis Series instead of the current one when
running multiple Analysis Series in parallel: (1.) Type of load sequence (Standard or General)
for Gravity and Static Pushover load cases. (2.) The operation to restore removed elements
(if any) for subsequent Gravity, Static Pushover, Dynamic Earthquake, Dynamic Force, and
Response Spectrum load cases with a preceding Gravity load case starting from unloaded
state. This issue was timing-dependent. The affected load cases might have failed to run
altogether, or they may have run using wrong Analysis Series data leading to incorrect
results. The issue most frequently manifested itself by failing to restore elements removed
for a gravity analysis in subsequent analyses, and consequently when it happened the
invalidity of results was obvious. To ensure correctness of results, it is recommended to re-
run models that have elements ignored for Gravity load cases if parallel analysis was used.
Results from models with Analysis Series ran sequentially were not affected.

3918 An incident was resolved where, when using the Upper/Lower Bound feature on an Inelastic
1D Concrete Material component without tension strength enabled, the following
Upper/Lower Bound options could result in a run-time error when trying to run analysis:
Effect on Deformation DU option "DU/DY", Effect on Deformation DL options "DL/DY" and
"DL/DU", Effect on Deformation DX options "DX/DY" and "DX/DU", and Effect on
Deformation Capacities options "DC/DY" and "DC/DU". In addition to resolving this issue, the
graphs in the component form showing the effect of U/L Bound Ratios for those
Upper/Lower Bound options have been updated to be consistent with the analysis behavior
of the component.

* 5853 An issue was resolved where, when running analysis series in parallel, an error message
"FILE ERROR - OPENING NEW FILE" could be present in the ECHO.txt file. This was a
reporting issue and did not affect analysis results.

* 5963 An incident was resolved where, when certain multi-degree-of-freedom nonlinear
components underwent a strain reversal between the L and R points of the backbone curve,
the residual strength of the component was fixed at the level where the reversal occurred
and did not drop further to the action defined for point R of the backbone curve. This issue
affected the following components: (1.) P-M2-M3 Hinge, Steel Rotation Type; (2.) P-M2-M3
Hinge, Steel Curvature Type; (3.) FEMA Column, Steel Type; (4.) V2-V3 Shear Hinge,
Displacement Type. This behavior was not common because load reversal when losing
strength is not common in most practical models.

* 6474 An issue was resolved where the YULRX-type cyclic degradation was not being considered
before the L-point when the E-P-P shape of relationship was used for the following
components: (1.) FEMA Column, Steel Type; (2.) FEMA Column, Concrete Type; (3.) P-M2-
M3 Hinge, Steel Rotation Type; (4.) P-M2-M3 Hinge, Concrete Rotation Type; (5.) V2-V3
Shear Hinge, Displacement Type.

Drafting and Editing
Incidents Resolved
* Ticket Description
* 5948 An issue was resolved where, in the Nodes task (Build Phase), the program may terminate

abnormally if the polar-coordinates option was used to add a new node while in a frame
view. This issue has been resolved and the option to create a new node in polar coordinates
now works as intended in all views.
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External Import and Export
Incidents Resolved
* Ticket Description

3341 An incident was resolved where a "Column, Inelastic Fiber Section" cross-section component
could not be exported with the option "Selected components of this type" if the fiber
section component contains structural or monitored fibers of the type "Inelastic Steel
Material, Buckling". This behavior has been corrected and "Column, Inelastic Fiber Section"
cross-section components can be exported with all material components.

4930 An Incident was resolved where the Fluid Damper and BRB compound components and the
Shear Wall, Elastic Section component could not be imported to Perform3D. Additionally,
the General Wall Compound Component could not be exported unless the component has
both "Conventional Shear" and "Shear from Diagonal Compression" defined. This behavior
has been corrected.

Graphics
Incidents Resolved
* Ticket Description

5770 An incident was resolved in the Nodes task (Build phase) where, when nodes are selected in
the Supports tab and the user moves to the Move tab under the Nodes tab, the selected
nodes in the display would be filled with a black color and appear invisible against the black
background. This issue has been resolved by clearing the node selection when leaving the
Support tab. This is a user-interface issue and does not affect results.

Loading
Incidents Resolved
* Ticket Description
* 3158 An incident was resolved where, when element loading was applied such that two or more

elements in different element groups but with identical element numbers were in listed
consecutively in the loads applied for a load pattern (as listed in the ECHO file), the loads
applied to those elements and the following elements could be incorrect. This issue was rare
and mainly affected models where one or more element groups had only one element.
When this issue occurred, the incorrect loads were reflected in the element response and
model behavior, including the Resultant Applied Loads reported in the ECHO file for the load
cases where the element loading was applied.

Results Display and Output
Incidents Resolved
* Ticket Description

5947 An incident was resolved where, in the Deflected Shapes task (Analysis Phase), the
thumbnail view of the structural response in the Plot Options group box may show a
response even if no load case is chosen for display. The thumbnail view of the structural
response is now cleared when switching to a new analysis series and updated when a load
case is chosen for display.

Structural Model
Incidents Resolved
* Ticket Description
* 3412 An incident was resolved where, if a "Linear P/V/M Hinge or Release" component was used

in a compound frame component, an element that the component is assigned to would
always be released in torsion. The behavior is revised so a "Linear P/V/M Hinge or Release"
component only releases the torsional degree-of-freedom if the torsion release is selected in
the component definition. Due to this change, the results for the example model that is
included with the installation of Perform3D differ slightly between previous version 7.0.0
and the present version 8.0.0.
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User Interface
Incidents Resolved
* Ticket Description

5769 An incident was resolved in the Nodes task (Build phase) where, when selecting nodes in the
Duplicate tab and switching to the Delete tab under Nodes, the number of selected nodes
was shown as zero (0) but the selected nodes were retained. The behavior has been
corrected so that the number of selected nodes reflects the selection and the selected
nodes will not be cleared when switching from the Duplicate to Deleted tab. The user can
manually clear selected nodes using the "Clear" button. This is a user-interface issue and
does not affect results.

5790 An incident was resolved in the Drift and Deflections task (Build Phase) where, when adding
a new drift and then switching to the deflection tab, the node selection in the display did not
reset and prevented the user from defining a deflection with the same nodes as the
previously defined drift. This was a user-interface issue and did not affect results.


