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SAFE v20.0.0 Release Notes
© 2021 Computers and Structures, Inc.

Notice Date: 27-September-2021

This document lists changes made to SAFE since v16.0.2, released 02-January-2018. Items marked with
an asterisk (*) in the first column are more significant.

Analysis
Enhancements Implemented
* Ticket Description

873 An enhancement was added with the command Analyze > Set Load Cases to Run which
allows controlling which load cases are to be run and other related options. This can be
useful to turn off nonlinear load cases when results are not needed at a particular time. The
"Run Analysis and Design" tool-button will only run those load cases that have been selected
by the Set Load Cases to Run command.

* 1806 An enhancement has been made to add a general mesher for floor area objects. The
generated mesh will primarily consist of quadrilateral elements, with triangles as needed
near transitions and discontinuities. The general mesher has less reliance on edge
constraints to provide continuity between floor elements than does the older rectangular
mesher. The general mesher is the new default. However, the rectangular mesher has not
been removed so as not to change results for older models.

3479 An enhancement was made to store analysis model generation warnings in the model so
they are available in the Analysis Message dialog from session to session.

4176 Optimizations have been made to speed up the plotting of deformed shapes and generation
of .AVI files for multi-stepped load cases. This will primarily affect direct-integration and
staged construction load cases in models with a large number of elements.

5255 An enhancement was made to the Nonlinear Parameters form (Define menu > Load Cases)
to provide more control over the iterative solution scheme used for a nonlinear static load
cases. For most problems the default parameters will be appropriate, but the user can make
changes for models where convergence behavior is difficult.

* 7171 An enhancement has been made to improve the consistency of analysis results on Intel and
AMD CPUs with an AVX2 instruction set. Most Intel and AMD CPUs released on 2015 or later
support AVX2 instruction set and should benefit from this enhancement. For nonlinear
analyses of numerically sensitive models, results should be more consistent when run on
different CPUs. For typical well-conditioned models and linear analyses, no significant
change is results is expected.

API
Enhancements Implemented
* Ticket Description
* 6620 An Application Programming Interface (API) has been added to SAFE that allows external

client applications to run SAFE or attach to existing instances of SAFE so as to manipulate
models. This includes such operations as opening and saving models, creating and modifying
models, running analysis and design, and extracting results. The client applications can be
written in several different programming languages, and can connect to SAFE through a .NET
or COM interface. Languages include Visual Basic, Visual C++, Visual C#, Python, Matlab, and
VBA (such as in Microsoft Excel). Access to SAFE model information is through API calls that
utilize the same database tables that are available in the graphical user interface (GUI).
Unlocked models can be created and modified using API functions that get and set tables
similar to how the interactive database editor works in the GUI. Data can be extracted from
locked or unlocked models using API functions that get tables similar to how tables are
displayed in the GUI. Documentation for how to use the API is provided in the help file "CSI
API SAFE v1.chm". Documentation for the data available in the tables can be obtained from
inside SAFE using the command Options > Database > Documentation to Word.
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Database Tables
Enhancements Implemented
* Ticket Description
* 7167 An item was added to the Options > Database menu to allow printing database table

documentation to Microsoft Word.

Design – Composite Beam
Enhancements Implemented
* Ticket Description
* 6458 Composite beam design has been added as a wholly new design feature in addition to the

existing concrete slab design. Horizontal steel beams can be drawn and assigned for design.
The design procedure considers composite and non-composite behavior as required, and
considers axial forces and vibrations when requested. Beams with web openings, including
castellated and cellular beams, can be designed. Design can be performed on the model as a
whole or interactively on individual members. With interactive design, various design
sections can be tried out, and the percentage of composite action and their camber can be
adjusted. Complete design results are available in comprehensive reports, tables, or
interactively. The following design codes are supported: AISC 360-16, AISC 360-10, AISC 360-
05, BS5950-1990, Chinese 2010, CSA S16-14, and Eurocode 4-2004. Beams with user-defined
web openings can be designed per the AISC 360-16, AISC 360-10, and AISC 360-05 codes
only. Beams subject to significant axial forces, castellated beams, and cellular beams can be
designed per the AISC 360-16 code only. The Chinese 2010 code requires a Chinese license.

Design – Slab
Enhancements Implemented
* Ticket Description
* 1014 An enhancement has been made to report integrated forces on a Section Cut. Three

methods are available to define these section cuts: (1) Define a group of shell and frame
objects whose nodal forces at joint objects also included in the same group are summed and
reported in tables. (2) Define a quadrilateral (quad) by its coordinates and a group of shells
and frame objects. In this case only the shell and frame elements of the analysis mesh of the
objects in the group that are cut by the quad are included in the sum of nodal forces. The
analysis nodes included in the summation are automatically picked based on which side of
the cut the summation is to be made. The results are reported in tables. (3) Draw a line on a
results view and the summation of nodal forces of the analysis elements cut are displayed
on screen for the load case of the results view. This cut can be saved as a Section Cut
defined by a quad. The program automatically creates the group of objects and the quad to
define it. The save can only be made if the results are displayed on an undeformed 2D view
showing force or stress results.For all three methods the user has options to obtain results
about a defined point, in a defined coordinate system, and using either an analysis-results or
a design-results sign and reporting convention.

2160 An enhancement was added for the command Display > Show Slab Design, and the
corresponding table "Concrete Slab Design Summary - Flexure and Shear Data", where span-
location details are now available based on the maximum moment and maximum shear
acting at the Start, Middle, and End of a span for a PT slab.

2891 An enhancement was made to the slab punching shear check for the CSA A23.3-14 design
code where a tolerance has been added when checking fy and f'c for enforcing the simplified
check based on CSA section 11.3.6.3. The purpose of this is to help avoid unexpected
changes in results due to small changes in material strengths.

* 3982 The concrete code “ACI 318-19” has been added for reinforced concrete and post-tensioned
design.

* 4687 An enhancement has been made where pre-compression due to PT is now reported for
every design strips in the tabular output.
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* Ticket Description
* 4688 An enhancement has been implemented where the moment capacity of design strips in a

model with PT are now reported for every strip station. Strip-moment capacities can also be
plotted in the graphical user interface.

* 4903 The National Annexes for Bulgaria, Germany, Ireland, Poland and Portugal have been added
as an option to the Eurocode 2-2004 reinforced-concrete and PT slab design.

* 5933 An enhancement has been made to the concrete beam and strip-based slab design to allow
user control to either include or exclude axial compression in flexural design if the axial
compression reduces the required reinforcement. Axial tension and axial compression that
increases the required flexural reinforcement is always considered. For post-tensioned
construction, all axial load is always considered. This user option is accessed through
concrete beam-design and slab-design preferences.

7102 An enhancement was made when using Chinese design code for checking slab punching
shear capacity in the presence of shear studs or shear rails which now uses GB50010-2010
Eqn. 6.5.3-1; previously GB50010-2010 Eqn. 7.7.3-1 was used.

7118 An enhancement was added for IS 456:2000 reinforced concrete slab design where option to
increase flexural rebar in slab has been added in the Design Preferences for enhancing
concrete slab shear capacity. When this option is activated and shear links are needed,
flexural rebar is increased to avoid shear links in slab/mat. Flexural rebar is increased only
when shear stress does not exceed the code specified maximum limit and when percentage
of reinforcement in slab is less than 3 percent.

Detailing
Enhancements Implemented
* Ticket Description
* 6135 A change has been made to separate the production of detailed drawings from SAFE into a

standalone product, CSiDetail v20, that interacts with SAFE. Detailing can still be performed
in SAFE, and the results displayed in the model windows and used for further design checks.
Detailing performed in SAFE can be exported to CSiDetail v20, when it becomes available, to
produce schematic drawing sheets that can be further edited.

Documentation
Enhancements Implemented
* Ticket Description

1157 The Help topic for Frame Property Modifiers has been updated to document the default
torsion-stiffness modifier used for Beams.

1313 A design verification example has been added for the punching-shear check of a circular
column per the ACI 318-19 slab design code.

1359 An enhancement was made in "Concrete Beam Flexure Envelope" and "Concrete Beam
Shear Envelope" tabular output by expanding the description for column "Location". The
description now includes the details of End-I, Middle and End-J locations.

1925 An enhancement was made by documenting the Modulus of Rupture used for floor cracked-
deflection calculations under "Material Property Data Form" when "Program Default" option
is used. This default is dependent on the slab design code and is documented for each code.

Graphics
Enhancements Implemented
* Ticket Description
* 825 The DirectX graphics used for model display has been upgraded to version 11. When SAFE is

run on machines that do not support DirectX 11, the graphics mode will revert to GDI+
(Standard graphics).

1105 An enhancement was made so that DirectX capabilities are now available on virtual
machines.

2155 The behavior of the graphical interface has been changed so that the zoom level is not
affected by editing operations such Move and Replicate. Previously these operations would
cause the view to zoom out to show the full model.



SAFE v20.0.0 ISO #RELSAF2000     27-Sep-2021 Page 4 of 10

* Ticket Description
* 3482 Enhancements have been made to DirectX graphics by using Direct2D in conjunction with

Direct3D. Specifically: (1.) Plan and elevation (XY, XZ, YZ and developed) views are generated
much faster and are clearer. (2.) Line quality for dashed lines, wide lines and selection lines
during editing, drafting and display has been improved for both 2D and 3D views. (3.)
Windows True Type fonts, including foreign language fonts, are available in both 2D and 3D
views. Previously only Arial fonts were available and did not cover some languages.

Installation and Licensing
Enhancements Implemented
* Ticket Description
* 823 SAFE is now available as a 64-bit application, providing increased speed and the ability to

handle larger models. SAFE v20 must be installed on a 64-bit computer running 64-bit
versions of Windows 8.1 or Windows 10. The 32-bit version is no longer available starting
with v20.0.0.

* 2323 The version number has been changed to v20.0.0 for a new major release.
* 6424 SAFE now utilizes cloud licensing by default, allowing access to the license by multiple users

and/or from multiple machines. The number of simultaneous users corresponds to the
number of licenses owned. Cloud licensing requires connection to the internet while using
the software, either directly or through a proxy. Connection to a company network or VPN is
not necessary. Licenses can be checked out for a limited time period to allow use while
disconnected from the internet. Legacy licensing options (Standalone and Network) are still
available upon request.

Loading
Enhancements Implemented
* Ticket Description
* 2436 An enhancement was made to update the default load combinations for Chinese design

codes based on recent changes to the National Standard for Reliability of Building
Structures.

Results Display and Output
Enhancements Implemented
* Ticket Description

507 An enhancement has been made to compute and report the elongation in tendons due to
the prestressing force at transfer. The elongations can be output in a tabular format or can
be displayed on the model in the graphical user interface (command View > Set Display
Options > Other Assignments > Tendon > Elongation)

* 691 An enhancement was made to expose non-structural geometric entities to the model called
Slab Panels. The Slab Panels are defined as portions of slabs surrounded by lines of support
or free slab edges. In earlier versions these were being generated internally using
rectangular grids and used in the program for automatic pattern loading and summarizing
displacement and soil pressure results. Slab Panel edges are now also used as lines for
meshing. Slab Panels can be added automatically using rectangular grids or already defined
support lines. They can also be drawn and edited onscreen. Replication is also available.

* 4689 An enhancement was made to provide more display options in the model window(s) for PT
tendons, including Number of Strands, Tendon System, Vertical Profile Control Points,
Vertical Profile Values, Total Length, Jacking Force, and Elongation. These can be turned on
and off using the command View > Set Display Options > Other Assignments.
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Structural Model
Enhancements Implemented
* Ticket Description

1027 The definition of new material properties has been enhanced as follows: (1) The "Add New
Material" button now uses the "Quick Material Definition" form. (2) The Quick Material form
now has an additional control to allow selecting pre-defined materials by country and/or
design code. (3) The country/code selector includes type "User" to allow immediate editing
of the property values. (4) Material type "Other" can now be selected, which only allows the
"User" option in the country/code selector.

1028 An enhancement was added allowing the aging coefficient to be specified in Nonlinear (Long
Term Cracked) analysis. Previously, the aging coefficient was always taken as 0.8, which is
still the default.

1045 An enhancement has been made to include bar spacing and the vertical offset from datum
in the form to Set View Options > Other Assignments > Slab Rebar Objects.

1376 An enhancement was made to allow more user control of wall meshing and restraint
duplication on added meshed joints. The old option of meshing based on floor mesh and a
maximum mesh size is the default.

* 1805 An enhancement was made to add non-structural geometric entities to the model called
Support Lines. The user can draw these objects as poly-lines to connect support points
(columns, walls, beams, restraints and springs) with each segment representing a span. A
layer tag (A or B) can be associated with these Support Lines. Each layer representing
Support Lines running essentially parallel to adjacent ones. The Support Lines in the two
layers then represent an interconnected mesh demarcating Slab Panels. The Support lines
can be used in the program to automatically generate Slab Panels, layout Design Strips and
layout Post-tensioning Tendons. The Support Lines are also used for meshing. The Support
Lines can be drawn and edited on-screen. They can also be generated by the program along
grid lines with some tolerance to allow for slightly offset columns and walls. Replication is
also available.

* 4331 An enhancement has been made to expand the Edit > Edit Shell > Merge Shells command to
merge two or more selected shell objects into a single shell. Previously only two selected
shells could be merged at a time. Additionally, a form is now provided to view the merge
prior to the operation being performed and select the existing shell from which the new
shell will inherit assignments. The following restrictions apply: (1.) Only floor elements can
be merged. (2.) Only shells with the same property and located at the same elevation are
merged. The new form will group the selected shells by property, and each group can be
viewed in the form by changing the property selection. For each group you can choose the
shell from which any assignments will be inherited. (3.) If more than two shells are selected
in a group, they should not overlap. If only two shells are selected, then any overlap will be
removed. (4.) Curved edges are not supported. Instead, they will be converted to multi-
segment straight lines.
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* Ticket Description
* 4332 An enhancement has been made by allowing shell objects to be defined by user-defined

internal meshes. The internal mesh must be made only of quadrilaterals and/or triangles.
These are used directly as analysis elements and no further meshing is done. The internal
mesh must be defined in the horizontal plane at the level of the model datum. The internal
mesh gets replicated when the shell object is replicated. The following commands are
provided for working with user-defined internal meshes: (1.) Draw > Draw Floor/Wall
Objects > Import User Mesh as Shell Object. This allows the import of ACAD3dFace entities
from a DXF file. The import allows for scaling and rotation and provides for an insertion
point. The outer boundary is stored as an area object with the internal mesh already defined
for analysis. (2.) Edit > Edit Shells > Explode User Mesh to Shells. This allows the stored
internal mesh of the selected shell objects to be converted to individual shell objects. All
shells created take their assignments from the parent and the parent object is deleted. (3.)
Edit > Edit Shells > Merge Shells to Create User Mesh. This allows selected shells that are
contiguous to be merged and made into fewer shell objects with internal meshes. The
merged shells created take their assignments from the first internal mesh object. This is the
opposite of the Explode command. (4.) Edit > Edit Shells > Convert Current Mesh to User
Mesh. This allows the current meshing for the selected shells to be converted to user-
defined internal mesh. This causes the meshing to remain constant from run to run, but the
user is responsible to assure that changes to the model should not require a change in
meshing. Otherwise the internal mesh should be removed and the appropriate meshing
option should be applied. (5.) Edit > Edit Shells > Remove User Mesh from Shell Object. This
allows the internal mesh to be removed and the outer boundary remains as a shell object
with all its assignments, and it is assigned the default meshing type for analysis which can be
modified by the user.

* 4333 An enhancement was done to speed up the creation of the analysis model. The area mesh
for each object is now saved from one run to another unless any item affecting its mesh is
changed in the model.

* 4685 Several enhancements have been made to the tendon vertical layout form designed to
collate all editable information related to tendon profile, geometry, loads, and losses in one
location. In addition, the drawing of the tendon profile has been enhanced and certain
parameters added to the display options in order to improve the readability of the tendon
profile and other information related to it. The parameters available for display include the
CG distance of tendon from the nearest concrete edge, the tendon radii of curvature, and
the balancing load due to pre-stressing force in tendon at transfer or after all long term
losses. The right-click information form has been removed as the enhancements
implemented provide all necessary information on the tendon layout form itself.

* 4884 An enhancement was made to add layer information for tendon, slab-rebar, and support-
line objects similar to what was already available for design-strip objects. The enhancement
is intended to streamline the grouping of various objects for the purpose of display and
selection.

* 6940 An enhancement was made to slab edge releases by allowing in-plane releases in addition to
the out-of-plane releases already available, and also by allowing partial fixity along the edges
for in-plane and out-of-plane behavior.

* 6973 An enhancement has been made to expand the Edit > Edit Shell > Merge Shells command to
merge two or more selected shell objects into a single shell. Previously only two selected
shells could be merged at a time. Additionally, a form is now provided to view the merge
prior to the operation being performed and select the existing shell from which the new
shell will inherit assignments. The following restrictions apply: (1.) Only floor elements can
be merged. (2.) Only shells with the same property and located at the same elevation are
merged. The new form will group the selected shells by property and elevation, and each
group can be viewed in the form by changing the property and elevation. For each group
you can choose the shell from which any assignments will be inherited. (3.) If more than two
shells are selected in a group, they should not overlap. If only two shells are selected, then
the overlap will be removed. (4.) Curved edges are not supported. Instead, they will be
converted to multi-segment straight lines.
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* Ticket Description
7204 An enhancement was made to the model-initialization form to allow selection of the

geographical region for generating default material properties. Material types (steel,
concrete, rebar, etc.) not available for the selected region will default to built-in material
properties.

User Interface
Enhancements Implemented
* Ticket Description

578 An enhancement was added where Joints, Frames, Shells, Strips, Tendons and other objects
can now be selected by their labels using the commands Select > Select > Labels and Select >
Deselect > Labels.

820 An enhancement was made to add two new tool buttons, Move Up in List and Move Down
in List, have been added for scrolling through plan views or elevation views.

1555 A new command, View > Set 3D View, has been added to provide more control over the
view angle and aperture (degree of perspective).

* 1926 An enhancement was made by adding an Apply button to many of the forms available under
the Assign and Display menus. This allows the form to remain open so that repeated
operations can be performed more easily, often with different selections of objects or with
different parameters.
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Analysis
Incidents Resolved
* Ticket Description

1188 An incident was resolved where the integrated Strip results for enveloping type
combinations (where correspondence between different responses is lost) could be
incorrect when the strips were skewed. In some cases, the envelope results could be smaller
than those for the contributing load cases.

1287 An incident was resolved where slab meshing was failing in some rare cases with
overlapping area objects, causing the slab area to be deleted from analytical model. When
this occurred, the error was obvious. Manually subdividing the slab before meshing avoided
this problem. This affected rectangular meshing, not the new general mesher.

1310 An incident was resolved where small triangular elements created due to the area mesh
were missing from analytical model.

2145 An error was resolved where a message "A fatal analysis error has occurred:
AnalysisModel::runSelf() Access violation..." was displayed when analysis was executed. This
issue occurred in rare cases where the analysis model was not correctly created by the
software for representing spring supports.

2221 An incident was resolved where clicking OK on the Response Spectrum Load case dialog
after viewing it would cause an invalid load case error when the model was run.

2893 An incident was resolved where running the analysis mode or creating the area mesh
sometimes displayed the message "An error occurred attempting to create analysis mesh!
Index was outside bounds of the array." This error generally occurred when the area
difference before and after meshing was higher than the tolerance value.

Database Tables
Incidents Resolved
* Ticket Description

2469 An incident was resolved where some models were unable to be saved when certain beam-
design data was missing, generating the error message "Error Creating database table for
tablekey Beam Properties 06". This was able to be corrected by importing the .$SF text data
file.

2909 An incident was resolved where changing a material name via interactive database editing
was not generating a warning or error message when material name change was not carried
over in all other tables that referenced the same material. Opening the Interactive Database
Editing form again in the same model caused form to not display correctly. This was a
cosmetic error and restarting SAFE did resolve this issue.

Design – Slab
Incidents Resolved
* Ticket Description

1937 An incident was resolved where concrete slab design sometimes reported required bottom
steel when there was only negligible negative moment in the slabs. This was a tolerance
issue. The results were conservative.

1948 An incident was resolved for the concrete frame design per code “TS 500-2000” in which the
design longitudinal and transverse rebar sometimes did not match with hand calculations
because of the lack of enforcement of the fy limit of 420 MPa.

1949 An incident was resolved for concrete beam design per the codes “BS 8110-97”, “Hong Kong
CP 2013”, and “Singapore CP 65-99” where the design minimum flexural rebar was not being
enforced for certain conditions, which then in turn affected the shear rebar design.

1994 An incident was resolved where the punching-shear check could fail to find the correct
punching perimeter for a drop panel when the model default length units were either m or
ft. This was due to a tolerance issue and only affected certain models.

2029 An incident was resolved for slab design where the punching-shear check was not
performed when the column had an insertion-point assignment.
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* Ticket Description
2894 An incident was resolved for BS 8110-97, Hong Kong CP 2013, and Singapore CP 65:99 design

codes where the punching-shear design report was reporting "Concrete Shear Capacity"
instead of "Allowable Shear Stress Limit" when the design failed at a column face. This was
just a reporting issue and design results were not affected.

2903 An incident was resolved where slab opening was not considered for punching shear check
at the drop panel location.

* 6009 An incident was resolved where in certain cases openings were not detected near columns
for floor punching shear checks or the excluded perimeter was not correct. This usually
happened when the column local axis was rotated. When this occurred the error was
obvious.

* 6853 An incident was resolved where the average punching-shear stress instead of the maximum
punching-shear stress was being checked against the stress limit for determining whether
shear reinforcement should be allowed.

Drafting and Editing
Incidents Resolved
* Ticket Description

1134 An incident was resolved where editing a curved wall using Reshaper tool was causing an
error message under certain unexpected conditions.

1397 An incident was resolved where the commands Edit > Copy followed by Edit > Paste were
only copying points, columns, and beams. Now selected slabs and drop panels will also be
copied and pasted.

2901 An incident was resolved where the program would sometimes terminate abnormally if the
mouse was double-clicked in any of the column-header cells of the data grid table on the
Tendon Vertical Layout Definition form. This form can be accessed by selecting a tendon
object and using the command Edit > Add/Edit Tendons > Edit Vertical Profile”.

External Import and Export
Incidents Resolved
* Ticket Description

7193 An incident was resolved that addressed the following issues related to the export of models
to .DXF files: (1.) Exporting a SAFE model to .DXF while selecting CAD units other than the
model database length units resulted in grid systems and slab strips being exported at
incorrect locations. (2.) Grid lines were always exported with their grid bubbles located at
their ends, irrespective of the grid bubble location specified in the model. Both of these
issues affected all versions of SAFE capable of exporting models to .DXF files. When these
errors occurred, the effect was obvious. Analysis and design results in SAFE were unaffected.

Graphics
Incidents Resolved
* Ticket Description

619 An incident was resolved where shell uniform loads would not display correctly due to
internal tolerance issues when merging overlapping areas with curved edges, sometimes
causing the software to terminate. This was a display issue only and did not affect results.

1552 An incident was resolved where the graphical display of loading or results over curved
beams would not show correctly. This was a display issue only and results were not affected.

1991 An incident was resolved where the perpendicular-projection snap was not working with the
reshape tool.

2007 An incident was resolved where deleting an object in DirectX view would reset the view back
to the default zoom level. This was not an issue with Standard Graphics.
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Results Display and Output
Incidents Resolved
* Ticket Description

1936 An incident was resolved where support reactions were not shown in either the graphical
user interface (GUI) or the tabular output for slab edges where edge releases were assigned.
This was just a display/reporting issue and analysis and design results were not affected.

1999 An incident was resolved where the text for moment/force-response diagrams and/or for
the reinforcement was being hidden behind the fill color used for the slabs when using the
command File > Print Graphics.

2564 An incident was resolved where the punching-shear detailed calculation report created via
the command File > Create Report option was showing the incorrect combination name and
was missing the design shear stress, concrete shear capacity, and punching shear ratio. This
was just a reporting issue and design results were not affected.

2568 An incident was resolved where an Error number 3024 could occur while printing reports.
This issue occurred when a temporary file could not be created in users local App Data
folder, and was not common.

Structural Model
Incidents Resolved
* Ticket Description

2333 An incident was resolved where Elasto-Plastic line springs were not working as expected.
This error did not affect area or point springs that were Elasto-Plastic or line springs of any
other type.

User Interface
Incidents Resolved
* Ticket Description

6020 An incident was resolved where the software would sometimes terminate unexpectedly
when changing the tendon profile from linear to reverse parabola for a span in the Tendon
Vertical Layout form.


