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CSiPlant v6.1.0 Release Notes 
© 2020 Computers and Structures, Inc. 

Notice Date: 29-November-2020 

This document lists changes made to CSiPlant since v6.0.0, released 21-July-2020. Items marked with 
an asterisk (*) in the first column are more significant. 

Analysis 
Enhancements Implemented 
* Ticket Description 
 3220 An enhancement has been implemented to more clearly display and save messages 

generated during analysis runs. These are the same messages that appear in the analysis 
LOG file but provided in a more concise format. Analysis messages are categorized as 
information, warnings, and errors. After the analysis is run, the message log is displayed 
based on the selection set in the Set Load Cases to Run form to always show or to only 
show when there are errors or warnings. This same text display is available any time using 
the command Analysis > Show Analysis Messages. The messages are also available in 
tabular format under table Analysis Results > Run Information > Analysis Messages. 
Messages are cumulative with subsequent runs until the model is unlocked, at which time 
the messages are deleted. Each message includes its type, message text, associated load 
case or stiffness case, operation being performed, date-time stamp, parallel run tag, run 
serial number, and machine name. The run serial number counts subsequent runs before 
the model is unlocked. The parallel run tag indicates which thread was used when analyses 
are run in parallel during the same analysis run. 

Database Tables 
Enhancements Implemented 
* Ticket Description 
 2533 An enhancement was added to include the X, Y, and Z coordinates of supports in the Pipe 

Support Reaction tables.  

Design – Piping 
Enhancements Implemented 
* Ticket Description 
 3151 An enhancement was made when creating a Design Request by copying an existing Design 

Request. The previous behavior would create a new Design Request with the same Design 
Request settings; however, all objects would have default design settings for the newly 
created request. This enhancement automatically copies both the Design Request settings 
and the any object design settings. 

 4923 An enhancement was made to the Design Report form allowing previous selections to be 
remembered the next time the form is opened. 

Drafting and Editing 
Enhancements Implemented 
* Ticket Description 
 77 An enhancement was added to update the Assign Frame Sections form to allow the user to 

select frames while the form is open.  
 114 An enhancement was added to snap to the elbow TIP and tee midpoint rather than the 

elbow endpoint and the tee branch endpoint respectively. This change is applicable when 
drafting, but it does not affect the functionality of the insert command.  

 159 An enhancement was added which automatically applies existing loads to a new element 
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* Ticket Description 
that is inserted and overlaps a loaded element. If the new element is inserted such that it 
overlaps part of or all of an existing element, the loads that were applied to the existing 
element and were located where the original and new elements overlap are then applied to 
the new element. Constant loads, such as temperature or pressure, that are applied to two 
original elements are then applied as a weighted average onto the new element, based on 
the lengths of the two original elements overlapped by the new element after the insert 
occurs.  

* 237 An enhancement was implemented allowing for the mirroring of frame and point elements 
about a user defined plane. This feature is accessible via command "Edit > Mirror" and 
applies to selected frame and point objects, with options to mirror the following 
assignments: point restraints, frame insertion points, groups, point local loads, frame 
distributed and point local loads, frame temperature loads, and frame strain loads. Two 
newly added context help topics "Mirror" and "Mirror Options" provide detailed 
information about the mirror operation, including the orientation of local axes and cross-
sections for the mirrored frame elements. 

 2691 An enhancement was added to check for identical loads when joining multiple pipes 
together with the Join Pipes command. If identical loads exist on the pipes, one singular 
load with the same properties and values is applied to the newly joined pipe. This simplifies 
the model but does not change results. 

 3186 An enhancement was added to allow users to snap to the midpoint of an object in order to 
see its coordinates. Previously, this option was only enabled while drawing objects. 

 3615 An enhancement was added to include a Measure tool, which includes line, angle, and area 
measurements. 

 4182 An Incident was resolved when reversing pipe flow or reversing frame connectivity changed 
the global orientation of supports. Supports are now oriented in the same global direction. 
Added new option "Align with Associated Pipe or Frame in Reverse Direction" for local axes 
of support objects. Distributed, point, uniform, temperature gradient, shear strain and 
curvature strain loads are updated to act in the same global direction after the pipe flow or 
frame connectivity are reversed. 

 4308 An enhancement was added to allow the user to display a global coordinate marker in the 
bottom left corner of the model view. The axes can be turned on in View > Show Global 
Axes and are applied independently in each model view.  

 4717 An enhancement was added to the Select menu to allow the user to select supports in the 
model based on support type and connection type. 

 4963 An enhancement was added to the "Select by Pipeline Labels" form to include an option to 
include connected pipelines in the selection. 

External Import and Export 
Enhancements Implemented 
* Ticket Description 
 5247 An enhancement was implemented where models created through PCF import files will 

automatically have their ambient temperature set to 70 degrees F instead of 0 degrees F. 
Additionally, the "Display Load Assigns" form has been updated to default the Temperature 
and Pressure type to Incremental instead of Absolute. 

Loading 
Enhancements Implemented 
* Ticket Description 
* 5372 An enhancement was made to a several of the time history function definitions to include 

one or more of the following options: 
1. Amplitude Shift, allowing specification of a Y-offset for the wave. 
2. Phase Shift, allowing specification of a phase shift for the wave. 
3. Initial Time Shift, allowing specification of a time delay to the start of the 
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* Ticket Description 
waveform. If no amplitude shift is specified, the Initial Time Shift represents a 
simple shift along the time axis. If an amplitude shift is also specified, the initial 
time shift effectively creates a linear ramp from (0,0) to the starting Y value of the 
waveform. 

4. Rectification, providing the ability to handle values less than the mean wave value. 
Half wave rectification sets all values below the mean to zero. Full wave 
rectification sets values below the mean to their absolute value. Rectification is 
applied prior to any amplitude shift so the mean value is equal to the amplitude 
shift. 

 
The updated functions and the specific enhancements applicable to each are: 
- Cosine - Amplitude Shift, Phase Shift, Initial Start Shift, and Rectification. 
- Sine - Amplitude Shift, Phase Shift, Initial Start Shift and Rectification. 
- Triangular - Amplitude Shift, Phase Shift, Initial Start Shift and Rectification. 
- Sawtooth - Amplitude Shift, Phase Shift, Initial Start Shift and Rectification. 
- User Periodic - Amplitude Shift and Initial Start Shift. 

Results Display and Output 
Enhancements Implemented 
* Ticket Description 
 202 An enhancement was added to allow the user to update the units in the tables being 

displayed without exiting the table.  
 4684 An enhancement was made to make the window title bar more descriptive when displaying 

loads. 

Structural Model 
Enhancements Implemented 
* Ticket Description 
* 4000 A new enhancement was implemented to easily model distributed supports such as soil or 

elastic foundations. Distributed supports can be applied to frames, pipes (straight pipe, 
elbows, tees, etc.), and piping components (flanges and valves). The new distributed type of 
support allows for a variety of behavior (gap, friction, multi-linear elastic/plastic, linear). 
These supports can be defined using the same support definition form used for other 
support types. 
 
The default spacing of the point supports generated to represent the distributed support is 
based on the relative stiffness of the support property and pipe/frame flexural rigidity. In 
addition, automatic meshing has been enhanced to provide the following controls: 

- Relative stiffness. The support spacing is based on the scaled relative stiffness 
spacing and is only used if the pipe/frame has a distributed-support assignment. 
Default scale factor is 1.0 

- Member dimension. The support spacing is based on the a multiple of the average 
member dimension. This meshing option can be utilized with or without a 
distributed-support assignment on the object. Default multiplier is 3.0. 

 
The reactions from distributed supports can be viewed in the analysis tables in both global 
and local coordinate system. In addition, contours of support reaction (force per unit 
length) can be viewed using the Display > Support Reactions command. 

 5159 An enhancement was added to set the default design code for materials and material 
properties to match the default design code used for design requests. 
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User Interface 
Enhancements Implemented 
* Ticket Description 
 34 An enhancement was added to the Assign Loads form to set the default load pattern based 

on the type of load being applied. 
 48 The descriptions of the various rigid stiffness on the "Pipe Analysis Options" form accessible 

via "Analyze > Set Analysis Options > Model Options" have been updated to more 
accurately describe how the rigid stiffnesses are calculated and used. 

 74 An enhancement was added where now double-clicking rows or columns in the Operating 
Cases tab of the Define Design Requests form activates or deactivates all the operating 
cases in the selected row or column.  

 267 An enhancement was added to display Wind Load Parameters in the Display Information 
form when an object is right-clicked. 

 4748 An enhancement has been implemented adding the "Assign Flanges to Valve Ends" form 
which automatically assign flanges to the ends of all selected valves. The assignment 
specifies the flange property and which side of the valves the flanges should be applied to.  

 4956 An enhancement was made to the Support Properties definitions allowing users to specify 
friction coefficients greater than 1.0. When the selected Support Type was a gap, the 
previous behavior restricted the values for friction to be between 0 and 1.0. Friction values 
defined in previous versions are unaffected by this enhancement. 
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Analysis 
Incidents Resolved 
* Ticket Description 
* 5366 An incident was resolved where analysis results could be affected by the active coordinate 

system in effect when the analysis was run. This would only occur if the active coordinate 
system had a non-zero origin translation or rotation. In general, a model with this issue 
would not converge rather than produce invalid results. Correct results were always 
produced when the Global system was in effect at the time the analysis was run. 

Design – Piping 
Incidents Resolved 
* Ticket Description 
 3469 An incident was resolved related to renaming of Design Requests that already have results. 

The previous behavior allowed the design request name to be changed after the request 
design was performed. The new behavior prompts the user to either delete the results and 
rename the request or else to not rename the request.  

* 5416 An incident was resolved where load combinations of type Absolute Add used in a Design 
Request caused the Design Request to not complete. 

Drafting and Editing 
Incidents Resolved 
* Ticket Description 
 411 An incident was resolved where objects that were overlapping and appeared behind 

another object were selected preferentially over the object that was visibly in front.  
* 4867 An incident was resolved which allowed the insertion of components along elbows and tees 

where there was not sufficient space to accommodate the insertion.  
 5097 An incident was resolved where points drawn on an elbow object would sometimes not be 

correctly associated with that elbow due to the dimension tolerances used. This issue 
would manifest itself through an unexpected orientation of the drawn object, such as the 
local axis aligning with the global coordinate system rather than the elbow tangential axis. 
This was a rare issue that occurred for specific elbow geometries and draw locations. All 
models created in previous versions of CSiPlant will be automatically updated so as to 
correctly associate the point and elbow objects when opened in the latest version. Note 
that the local axes of these point objects will not be updated. 

 5291 An incident was resolved which prevented users from drawing angled tees from the 
connection point of two parallel pipes.  

 5297 An incident was resolved which prohibited the drawing of a new pipe that would create an 
angled tee when two pipes previously connected at an angle to one another without an 
elbow between them. If the new pipe is drawn parallel to one of the existing pipes, it will 
now prompt the creation of an angled tee. If any of the pipes have different pipe property 
sets, a reducer will always be inserted on the J side of the new tee. 

Graphics 
Incidents Resolved 
* Ticket Description 
 184 An incident was resolved where drafting and snapping errors occurred when the user 

attempted to draw in a grid other than "Global". These errors included the following: 
- Cursor snapping to points that did not exist in the model 
- Drawn elements appearing in a different location than where the click to draft 

occurred 
- Inability to create tees 
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Loading 
Incidents Resolved 
* Ticket Description 
 2886 An incident was resolved in which a load combination was available as a possible load case 

to be included in the load combination itself. This is no longer allowed. 

Results Display and Output 
Incidents Resolved 
* Ticket Description 
 3546 An incident was resolved where tees that were drawn into the pipe main, causing the flow 

direction to be toward the tee main, would display incorrect results contours. This was a 
display issue only. Tabular results were correct. 

 4022 An incident was resolved where results contours were displayed incorrectly when the 
minimum and maximum values were user defined and did not fully contain the result values 
to be displayed.  

 4922 An incident was resolved related to the presentation of selected items in the design 
reports. The previous behavior did not limit presented results to the selection, instead 
presenting all available results.  

 4924 An incident was resolved where pressure loads on elbows were not being displayed. Design 
results were unaffected. 

User Interface 
Incidents Resolved 
* Ticket Description 
 3404 An incident was resolved where pressing any key or key combination assigned to a shortcut 

before opening a model caused the program to terminate unexpectedly.  
 5261 An incident was resolved where a new model could not open if the user attempted to do so 

while the current model had an active grid system other than Global.  
 


